Started 3 months agoMay 10, 2026Lasted less than a minuteMay 10, 20268:168:16 AMUTC
Affected
Website
Operational from 8:16 AM to 8:16 AM
Updates
Update
UTC
Update
UTC
This incident has been resolved.
Resolved
UTC
Resolved
UTC
We have identified that the FivData chrome extension is failing to install. This is caused due to an error on our CI/CD pipelines. This issue is fully identified and patch is released to Chrome Webstore today.